PowerCMS™

12月12日東京、12月19日大阪にて PowerCMS X 製品発表会を開催いたします。大阪会場はお席に余裕がございます。

動作環境

ホーム > PowerCMS > 動作環境

サーバ動作環境

サーバOS
  • Linux, Solaris/Unix, BSD
    • nginx + starman + Perl 5.18.x にて動作確認を行っております。
    • apache2 Perl 5.8.8 にて動作確認を行っております。
  • Mac OS X
  • Windows Server 2008(R2)
    • 2008 R2 + Strawberry Perl 5.20.x(32bit)にて動作確認を行なっております。Perl は exe 実行となります。
  • Windows Server 2012 /2012 R2
    • 2012 / 2012 R2 の動作確認環境は Microsoft Azure + Strawberry Perl で行なっております。
    • 2012 / 2012 R2 + Strawberry Perl 5.20.x(32bit)にて動作確認を行なっております。Perl は exe 実行となります。
ウェブサーバ
  • Apache HTTP Server 2.0 以上
  • Microsoft Internet Information Services 7.5 以上
  • nginx 1.2.0 以上(CGI もしくは PSGI および DynamicMTML 実行環境が別途必要となります)
データベース
  • MySQL バージョン 5.0 以上 (MySQL 5.7 で動作確認を行っています。)
データベース(PowerCMS アドバンスト を利用する場合)
  • MySQL バージョン 5.0 以上 (MySQL 5.7 で動作確認を行っています。)
  • Microsoft SQL Server 2012
  • Microsoft SQL Server 2012 R2 (Microsoft Azure SQL データベース)
  • Microsoft SQL Server 2014 (Microsoft Azure SQL データベース)
  • Oracle Database 11g R2
  • Oracle Database 12c
  • Microsoft SQL Server を使う場合、Perl のデータベースドライバは DBD::ODBC 1.25 以上をご利用ください。
  • Oracle Database を使う場合、Strawberry Perl でデータベースドライバは DBD::Oracle 1.25 以上をご利用ください。ActivePerl 64-bit 版は利用できません。
サーバソフトウェア
  • Perl 5.8.1 以上(5.18.x を推奨 / Perl 5.22.x 以上は、未検証のためサポートされません。)
  • PHP 5.3 以上 PHP 7.0 以下
必須 Perl モジュール
  • CGI
  • Image::Size
  • File::Spec (バージョン0.8以上)
  • CGI::Cookie
  • Scalar::Util
  • LWP::UserAgent
  • parent
  • Archive::Zip
  • Image::Magick
  • XML::Parser
  • Estraier.pm(エンタープライズ検索を利用する場合に必要)
  • Digest::SHA1(エントリを Twitter へつぶやくために必要)
  • HTTP::Date(Link プラグインで必要)
  • Text::CSV_XS(改行を含む CSV ファイルをインポートするために必要)
  • MIME::Parser(携帯メール投稿のために必要)
  • Crypt::SSLeay(Google Analytics との連携に必要)

また、データベース モジュールとして以下の Perl モジュールが必要です。

  • DBI (バージョン1.21以上)
  • DBD::mysql
  • DBD::ODBC (バージョン1.25以上、アドバンスト版で Microsoft SQL Server を利用する場合のみ)
  • DBD::Oracle(バージョン1.25以上、アドバンスト版で Oracle Database を利用する場合のみ)

これらの Perl モジュールは、PowerCMS チェック用 CGI の mt-check.cgi を実行することで、インストールされているかどうか確認できます。mt-check.cgi については『サーバーのシステム情報の確認』の項を参照ください。

ダイナミックパブリッシング
  • PHP 5.3 以上
  • PDO_MYSQL ドライバ等の、使用するデータベースに対応した PHP Data Objects 拡張モジュールが必要です。
  • ウェブサーバーが Apache の場合は AllowOverride ディレクティブで .htaccess ファイルによる設定の上書き許可が必要です。
文字コード
  • UTF-8

クライアント動作環境

  • Google Chrome
  • Internet Explorer 10 / 11(IE 11 を強く推奨)
    • IE 11 は、PowerCMS 4.02 以降のバージョンで対応しています。
    • デスクトップ用 Internet Explorer のみの対応となります。
  • Safari
  • Mozilla Firefox
  • iPhone: Safari 最新版
  • Android: Chrome 最新版

制限事項

  • リッチテキストエディタ TinyMCE 4 は、IE 10 では動作しません。IE10 でご利用の場合、環境変数 TinyMCEVersion 3 を指定してください。なお、IE10 はマイクロソフトのサポートが終了しているため、IE11 のご利用を強く推奨しております。
  • スマートフォンでは以下の機能はご利用いただくことができません。
    • リッチテキストエディタによるテキスト編集
    • サイドメニューのアイテム関連機能タブ
    • 画像アイテムの編集
    • アドレス帳関連機能
    • Copy2Public による同期関連機能
    • Power Studio を使った開発

Microsoft および Windows Server, SQL Server, Internet Explorer は、米国 Microsoft Corporation の、米国およびその他の国における登録商標です。
PowerCMSはアルファサード株式会社の登録商標です。
その他、本サイトに記載されている製品・サービス名は、各社の商標または登録商標です。
本サイトにおいては、体裁上の都合により製品・サービス名の表記において商標登録表示、その他の商標表示を省略していますので、予めご了承ください。

お問い合わせ

お問い合わせフォームがご利用できない場合は、以下のメールアドレスからも受け付けております。
contact@alfasado.jp

製品資料ダウンロード

パンフレットデータ、提案用資料などがダウンロードできます。